A [Brief] Introduction to Excel
Wellesley College, February 2015

You can find example data and a copy of this handout in a shared folder on Google Drive, called “Intro to Excel Workshop”. You can also directly access the folder here:  http://tinyurl.com/excelintroworkshop

Where to Find Help
- This guide – especially the links to additional resources and tutorials.
- Google or your favorite search engine – there are a lot of online resources (videos, tutorials, message boards) for Excel!
- The Help Desk – if you have technical problems (e.g., installing MS Office, Excel won’t open, etc).

Excel Versions
This guide was written using Microsoft Excel 2010 on a Windows computer. If you are using a newer version of Excel or if you are working on a Mac, some things may look a bit different. However, the general principles for formatting, writing formulas, and creating charts should be the same. To figure out how to do the same things in your version of Excel, try a Google search or check out the links in each section of this guide.

Getting around in Excel
Anatomy of a Spreadsheet
- Workbook – an Excel file (.xlsx), made up of worksheets
  - Worksheet – individual spreadsheets within a workbook
    - Columns – referred to by letters across the top
    - Rows – referred to by numbers down the side
    - Cells – referred to by a column letter + row number (e.g., A1, B1, A2, A3, etc)

Navigating & Shortcuts
Excel comes with a lot of keyboard shortcuts that can make it easier and faster to use.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow keys</td>
<td>Move left, right, up and down in the worksheet.</td>
</tr>
<tr>
<td>Enter</td>
<td>Accepts your entry and moves the active cell down one.</td>
</tr>
<tr>
<td>Shift+Enter</td>
<td>Accepts your entry and moves up one.</td>
</tr>
<tr>
<td>Tab</td>
<td>Accepts your entry and moves the active cell to the right.</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>Accepts your entry and moves left.</td>
</tr>
<tr>
<td>CTRL+Arrow keys</td>
<td>Moves to edge of a range.</td>
</tr>
<tr>
<td>Shift+Arrow keys</td>
<td>Selects current cell plus 1 cell to right/left/top/bottom.</td>
</tr>
<tr>
<td>Shift+CTRL+Arrow keys</td>
<td>Selects cells to the ends of the range.</td>
</tr>
<tr>
<td>CTRL+C or Ô+C</td>
<td>Copies selected cells.</td>
</tr>
<tr>
<td>CTRL+V or Ô+V</td>
<td>Pastes copies cells to the selected location.</td>
</tr>
<tr>
<td>CTRL+S or Ô+S</td>
<td>Saves the open worksheet.</td>
</tr>
</tbody>
</table>

More Excel Shortcuts on Macs and Windows:  http://exceljet.net/keyboard-shortcuts
Copy/Paste

Step 1. Select the cells you want to copy.

3 ways to select large parts of a worksheet:

- To select an entire row: click on the row number. Click and drag to select >1 row.
- To select an entire column: click on the column letter. Click and drag to select >1 column.
- To select an entire worksheet: click on the solid cell with a triangle at the top-left.

3 ways to select specific cells:

- Click and drag the mouse to select the cells you want
- Hold down the SHIFT key and then click to select the cells you want
- Use keyboard shortcuts to select the cells you want (see above)

Step 2. Copy the selected cells (CTRL+C or ⌘+C)

Step 3. Click where you want to paste, then use CTRL+V or ⌘+V to paste.

Note: When pasting from other programs (including websites), try right-/CTRL-clicking and selecting Paste Special rather than using the keyboard shortcut. Paste Special includes a lot of useful options—try out each one to see how it works.

Insert or Delete Columns & Rows

- To insert rows/columns: Right-/CTRL-click on the row number or column letter where you want to add a new row or column and select Insert. A row will be inserted above or a new column will be inserted to the left of where you right-clicked.
  - If you select >1 row or column, that number of rows or columns will be inserted.
- To delete rows/columns: Right-/CTRL-click on a row number or column letter and choose Delete to remove the selected rows/columns.
- You can also use the Insert and Delete buttons in the Cell group of the Home tab.
Staying Organized

Worksheets
Use different worksheets to organize your data, tables, and charts. Give each worksheet a useful name.

- Click on the worksheet tab to view its contents.
- Double-click on a worksheet tab to rename it.
- Click on a tab and drag it to change the order.
- Right-/CTRL-click on a worksheet tab to find additional options.

Formatting
Use font and cell formatting to visually organize data within a worksheet. Most formatting tools can be found in the Home tab. You can also right-/CTRL-click on cells and choose Format Cells to set the number format, borders, font, etc. Try out different options to see how they work.

Other Handy Tricks
The Data tab includes some useful ways to view your data and make spreadsheets easier to read.

- Sort data: http://tinyurl.com/excelsort
  Sort data by column contents or color. You can also sort your data by multiple columns.
  - Select all of your data (CTRL+A or +A)
  - In the Data tab, click the Sort button. Check ‘My data has headers’ if the columns include the name as well as the data.

- Freeze/lock columns or rows: http://tinyurl.com/rowfreeze
  Freeze specific rows or columns so that you can always see that area of the worksheet no matter where you scroll. Especially useful for column headings.
  - In the View tab, under Freeze Panes.
Formulas
In addition to numbers and text, you can fill cells with formulas to perform calculations.

Important things to remember:

- **Formulas always begin with an equals sign (=).**
- **Order of operations applies.** Use + for sum, - for subtract, * for multiply, / for divide, and ^ to raise something to a power (e.g., $10^2 = 100$).
- **Both numbers and cell contents can be used in formulas.**
- In formulas, **cells are referred to by their unique letter+number combination** (A4, B4, C6, X9, etc).

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Name</td>
<td>Score</td>
</tr>
<tr>
<td>2</td>
<td>Rachel</td>
<td>80</td>
</tr>
<tr>
<td>3</td>
<td>Paula</td>
<td>77</td>
</tr>
<tr>
<td>4</td>
<td>Ina</td>
<td>89</td>
</tr>
<tr>
<td>5</td>
<td>Julia</td>
<td>98</td>
</tr>
</tbody>
</table>

A formula for the average score:

$$=(B2+B3+B4+B5)/4$$

Functions
Functions are just built in formulas that are designed to accomplished specific tasks. Each function has a name to call on it, and then the components of the function (numbers, cells) go inside parentheses. So for the above score data:

- **=SUM(B2:B5)** is equivalent to **=B2+B3+B4+B5**
- **=MEAN(B2:B5)** is equivalent to **=(B2+B3+B4+B5)/4** or **=SUM(B2:B5)/4**

When you begin typing a formula in a cell, Excel will show you possible matching formulas as well as a brief description.

Once you choose a function, Excel shows you a prompt of the different parts required to use the function. Anything in bold is required, and anything in brackets is an option.

The **Formulas** tab includes commonly used functions, as well as a way to search for functions. Highlight the cells you’re working with, then click **Insert Function** in the Formulas tab. In the Insert Function window, you can search for functions and find out more about how to use a specific function.

**A List of Functions by Category:** [http://tinyurl.com/functionsbycategory](http://tinyurl.com/functionsbycategory)
Copying Formulas

Often you’ll want to use the same formula on an entire column or set of numbers. There are several ways to copy your formula:

1. Click on the cell containing the formula.

2. Hover your mouse over the bottom right corner of the selected cell, where you’ll see a small black square. Your mouse should turn into a solid black cross. Click and drag down to the last cell you want to fill with the formula.

3. Alternatively, double-click on the small black square at the bottom right corner of the cell. The cell contents will auto-fill all the way down to the last row with content.

2-minute video demonstrating auto-filling cells: http://tinyurl.com/autofillvid

You’ll notice when you copy formulas that the formula adjusts automatically for the new values—in other words, cell references within the formula are relative and update to the new location. For example, when I dragged the formula in cell D2 down to cell D3, cell references in the formula updated from B2:C2 to B3:C3.

If you want a cell reference in a formula to remain constant (e.g., each column should be divided by a certain cell’s data), add a dollar sign ($) in front of that cell’s reference in the formula to “lock” it. This is useful when doing calculations using a fixed rate or value (e.g., price including tax).

For example, if I copy down =D2-E2 to the next cell, the next cell’s formula would read =D3-E3. If I add $ signs in front of E and 2, my formula would read =D2-$E$2 and when I copied it down to the next cell it would read =D3-$E$2. No matter where I put the formula in the spreadsheet, the first cell reference in the formula will change and the second cell reference in the formula will remain E2.

Note: If you move a formula or Cut/Paste a formula, the cell references will not update. The cell reference only update if you copy or autofill the formula.

Tutorials: Formulas & Functions

5-minute video: Autofilling & setting absolute cell references in formulas http://tinyurl.com/constantcellrefs
More info about moving & copying formulas: http://tinyurl.com/movecopyformulas
Video Tutorial/Course from Microsoft: http://tinyurl.com/formulafunctiontutorial
Graphs & Charts
Use the Insert tab (Windows) or Charts tab (Macs) to create graphs and figures using your spreadsheet.

Basic Steps
1. Select the cells that contain what you want to graph. You can include column headings.
2. Go to the Insert tab (PCs) or Charts tab (Macs) and choose the type of graph you want to make.
3. A graph will appear in your worksheet with defaults.
4. Add labels, units, a better title, better colors, and anything else that will make your graph easier to interpret.
   a. When a chart is created or selected, the Charts Tools appear (highlighted in green on PCs/purple on Macs) as new tabs in the Excel Ribbon along the top. Use these tools to change the appearance of your graph. Use the Layout and Format tabs to change parts of the chart.
   b. Or right-/CTRL-click on an element of the graph (e.g., an axis, the legend, etc) and choose Format.

Tips for making attractive Excel charts: http://tinyurl.com/formatcharttips

Choosing a Chart Type
Different types of charts are useful for showing different types of information and conveying different aspects of the data. You’ll probably mostly be using scatter and line charts, though bar charts can be useful if when comparing categories or groups.

You can make line graphs 2 ways: Scatter with Straight Lines chart type under Scatter 2D Line chart type under Line.

A description of chart types: http://tinyurl.com/excelcharttypes

Modify or Add Data to a Chart
If you want to add a second data series (e.g., another set of bars, another set of lines, another set of scatter points) to an existing chart, there are several ways to add more data series to your chart.

1. Right-/CTRL-click on the chart and choose Select Data.
2. Click the Add button.
   a. Click the Select Range button to select the series values.
   b. After you have selected the cells in the spreadsheet that hold the new series values, click on the button to return to the Edit Series window.
   c. You can manually type in the name or choose it from the spreadsheet. Click OK to return to the Select Data Source Window.
3. In the Select Data Source window, you can also alter the X axis labels. Click OK when you’re done.
4. The second data series will appear on your chart in a different color.

Video demonstration (skip to 0:58): http://tinyurl.com/adddataseries
1 minute video tutorial (a different method): http://tinyurl.com/adddataseries2
Add a Trendline

A trendline is a best-fit line through the data on your graph. To add a trendline to a graph:

1. Right-/CTRL-click on the data series (line, points, bars, etc) in the graph and choose Add Trendline.
2. Choose the type of trendline that you want to add, depending on your data. If you’re not sure what to choose, start with Linear.
3. Check Display Equation on Chart to get the equation for the trendline. If you chose a linear trendline, it will be a slope-intercept equation.
4. Click Close.

To remove a trendline, click on the line in the graph and hit the Delete key on your keyboard.

More about trendlines in Excel: [http://tinyurl.com/exceltrendlines](http://tinyurl.com/exceltrendlines)

Tutorials: Charts

Creating a Chart from Start to Finish (text tutorial): [http://tinyurl.com/chartutorialtext](http://tinyurl.com/chartutorialtext)

How to Create a Chart (video tutorial): [http://tinyurl.com/chartutorialvideo](http://tinyurl.com/chartutorialvideo)

Resources for Learning More

UMich Guide to Excel

[http://guides.lib.umich.edu/excel](http://guides.lib.umich.edu/excel)

A great reference site covering everything we talked about today

Getting Started with Excel on a Mac (pdf file)

[http://tinyurl.com/excelonmac](http://tinyurl.com/excelonmac)

Because some things are a bit different in Excel on a Mac vs. PC